Welcome
Welcome to vistafirewallcontrol

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

Bugs and suggestions

The product edition for XP, 2003, 2000

Re: Bugs and suggestions

Postby VistaFirewallControl » Mon Jul 19, 2010 12:50 pm

We tried to check the speed with iperf on a network.
Clean system - 166Mbit/s
FW installed with Mode:EnableAll – 154Mbit/s
FW installed with Mode:Normal - 151 Mbit/s
So we did not find any significant performance degradation.
How to reproduce the degradation?
Are there any other FWs/AVs installed on your system simultaneously?


>Anyway, I've found real reason - any W7FC rules are not work, if there non latin(english) letters in the path

Tried to set system local to Russian and rename a file (actually netcat) to a random name with Russian letters.
The renamed netcat was detected exactly as named and followed the rules set without any problems.
How to reproduce?
All the experiments were made on clean XPSP3 installation.
Any ideas?
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Bugs and suggestions

Postby Oleg » Fri Jul 23, 2010 5:09 pm

I'll try to reproduce it later, now have no time.

What you think about this options ? :)
Image
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

Re: Bugs and suggestions

Postby VistaFirewallControl » Mon Jul 26, 2010 7:40 am

Another user has supposed the problem is in IE8 (seems all the problems you reported where IE8 related).
There were several confirmed cases of IE8 being installed on clean system generated problems on its own.
Regarding the options.
- an application sign must not be used for an automated security decision. The is lot of signed application users prefer not to allow to the internet - various auto updates for instance.
And vice versa, there is a lot of very popular unsigned application, which are expected safe for the network access by million users.
- "block before boot" will be implemented in the nearest version. (*)
- "protect the service from termination" is scheduled.(*)

(*) we do not think a user defined option is required if the option appears operable, we are afraid of some drawbacks of the possible overprotection.
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Bugs and suggestions

Postby Oleg » Mon Jul 26, 2010 12:38 pm

VistaFirewallControl wrote:Another user has supposed the problem is in IE8 (seems all the problems you reported where IE8 related).
There were several confirmed cases of IE8 being installed on clean system generated problems on its own.

Yep, i wrote about this in my post :D Anyway, I'm also test your software on clean system and update IE to 8.0 .
VistaFirewallControl wrote:- an application sign must not be used for an automated security decision. The is lot of signed application users prefer not to allow to the internet - various auto updates for instance.
And vice versa, there is a lot of very popular unsigned application, which are expected safe for the network access by million users.

It is only option(turned off by default), nobody forces user to turn it on. And this would be useful for some power users. What do you think ?
VistaFirewallControl wrote:(*) we do not think a user defined option is required if the option appears operable, we are afraid of some drawbacks of the possible overprotection.

No-no, such type of options MUST be selectable. Anyway, you can do some things for prevent this:
a) Warning something like "I'm understand risks".
or
b) Password protected options for more advanced security.
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

Re: Bugs and suggestions

Postby Oleg » Thu Aug 05, 2010 3:37 pm

VistaFirewallControl wrote:>Anyway, I've found real reason - any W7FC rules are not work, if there non latin(english) letters in the path

Tried to set system local to Russian and rename a file (actually netcat) to a random name with Russian letters.
The renamed netcat was detected exactly as named and followed the rules set without any problems.
How to reproduce?
All the experiments were made on clean XPSP3 installation.
Any ideas?

Still have this problem on clean system.
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

Re: Bugs and suggestions

Postby VistaFirewallControl » Fri Aug 06, 2010 9:07 am

The question is still how to reproduce without installing dubious third parties.
What is the path of the application at least?
Where is the difference between the experiment we made and the problem you have discovered
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Bugs and suggestions

Postby Oleg » Fri Aug 06, 2010 5:11 pm

VistaFirewallControl wrote:The question is still how to reproduce without installing dubious third parties.
What is the path of the application at least?
Where is the difference between the experiment we made and the problem you have discovered

I suppose, that happens because running from Desktop. Desktop folder in russian version of WinXP
Code: Select all
C:\Documents and Settings\admin\Рабочий стол\


And I've found another bug - when folder with application is moved to other folder "path" in Alert window are previous.
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

Re: Bugs and suggestions

Postby VistaFirewallControl » Fri Sep 17, 2010 12:11 pm

>I suppose, that happens because running from Desktop. Desktop folder in russian version of WinXP
3.8.157 fixed
>And I've found another bug - when folder with application is moved to other folder "path" in Alert window are previous.
Please try on 3.8.157 and report
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Bugs and suggestions

Postby Oleg » Mon Nov 29, 2010 11:27 pm

4.1.1.23 tested, both of above bugs is fixed, thanks.
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

Re: Bugs and suggestions

Postby Oleg » Thu Dec 02, 2010 12:18 am

VistaFirewallControl wrote:>2) Why applications must be restarted to get network access(after allow), this is very uncomfortable.
Any initial access attempt of non-listed applications are blocked. Evidently it happens only once per application Almost any modern application “understands” if a connection is failed automated retry is required.
Some application however requires retrying manually. There are also rare old fashioned applications (old IE for instance) have to be restarted just to reestablish the connection.
If you find a lot of application relying on the 100% internet connection success only we would consider to implement “waiting-for-user-permissions” logic.
Actually “initial-access-is blocked” approach is realized in Vista/Windows7 product branch and causes no problems usually.

Would be great, because I've some programs, that can't reconnect after "initial-access-is blocked" - apple iTunes with iPhone - bunch of apple proccesses fails. Also I've program in russian that cycles in autoupdate, update goes ok only when I've choose "Enable all" mode.
BTW thanks for license. :)
Oleg
 
Posts: 18
Joined: Thu Jul 08, 2010 11:34 am

PreviousNext

Return to XP Edition

Who is online

Users browsing this forum: No registered users and 0 guests

cron
suspicion-preferred