Welcome
Welcome to vistafirewallcontrol

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

Error while upgrading to 5.0.0.15

The product edition for XP, 2003, 2000

Error while upgrading to 5.0.0.15

Postby enricob » Sun Jun 10, 2012 11:38 pm

Hello, I have problems with "Windows7FirewallControlFree version 5.0.0.15".
I had tried to upgrade from version 4.1.x to version 5.0.0.15 but the system reported an application error and now I have lost connectivity.
I have uninstalled version 4.1.x without any problem, then installed version 5.0.0.15 and rebooted.
At first reboot with version 5.0.0.15 all connectivity is lost, and "System" event log reported the following errors (ordered as they appears in the logs):
- Service "NetBT" error: "Initialization failed because the device driver could not be created."
- Services "DHCP", "DNS", "IPSEC" with error: "A device attached to the system is not functioning."
- Services "Windows Firewall", "TCP/IP", "Network Location Awareness(NLA)" error: "The system cannot find the file specified"

Windows7FirewallControl application is loaded but is not showing any application in the "Windows 7 Firewall Control -> Program" tab, I suppose due to the fact that the network drivers are not loaded.

Now I tried to uninstall "Windows7FirewallControl" but the unistall crashed with an application error, logged in eventlog "Application":
"Faulting application windows7firewallservice.exe, version 5.0.0.15, faulting module windows7firewallservice.exe, version 5.0.0.15, fault address 0x0002099c."

Rebooted the system.
After rebooting errors are almost the same, with the addiction of a "Windows7FirewallService" service error, (ordered as they appears in the logs):
- Service "NetBT" error: "Initialization failed because the device driver could not be created."
- Services "DHCP" and "DNS" with error: "A device attached to the system is not functioning."
- Service "Windows7FirewallService" error: "The system cannot find the path specified"
- Services "IPSEC" with error: "A device attached to the system is not functioning."
- Services "Windows Firewall", "TCP/IP", "Network Location Awareness(NLA)" error: "The system cannot find the file specified"

Now the "Windows7FirewallControl" folder in "ProgramFiles" is gone and the filtering driver is gone.
In "Services" remains the service "Windows7FirewallService" and I removed it by using "sc delete Windows7FirewallService".
I also discovered that the system driver "c:\windows\system32\ipnat.sys" has been deleted from the system, and same goes for system drivers "TCPIP.sys" and for driver related to "Network Location Awareness".
System now has no connectivity.

Tried a system restore with no luck, seems that other drivers are missing and now seems that AVG antivirus has some corrupted modules.
Now I am trying to see if there is a restore point not corrupted and which driver is missing, still investigating.

Questions:
- Any idea of what happened?
- Is it possible to download Windows7FirewallControlFree version 4.1.x?
In the website I found only version 4.1 Plus but not version 4.1 Free:
http://www.sphinx-soft.com/download/W7F ... -Setup.exe

Thank you.
enricob
 
Posts: 1
Joined: Sun Jun 10, 2012 10:10 pm

Re: Error while upgrading to 5.0.0.15

Postby VistaFirewallControl » Tue Aug 07, 2012 9:35 am

>- Any idea of what happened?

The specific system dependent accident or incorrect permissions settings.
If you started performing system level manual actions beyond the default installed/uninstaller you should continue with the manual actions at your own risk as well.
The default uninstaller removes the product completely. TrayIcon/RightClick/Mode:EnableAll switches the firewall (on consistent installations) off completely.
The installation can be made on the top to recover the uninstaller (it it's been removed manually accidentally)
The problem may be caused by a conflict with other security related products (The XP compatibility specifics) for instance.

> Is it possible to download Windows7FirewallControlFree version 4.1.x?

The free versions are mostly equal in the functionality and the installation details.
We do not see any reasons to keep the previous free versions publicly available.
Please contact the support directly for the previous versions availability if required.
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Error while upgrading to 5.0.0.15

Postby PietO » Sat Aug 25, 2012 10:40 am

Investigation an other problem (see other thread DisableAll except one IP-address), i decided to deinstall my licenced XP-W7FC en reinstall the latest version.

I encountered almost identical problem as above reported by enricob: TCP/IP not functioning, system file(s) missing, reinstalling W7FC V5.0.0.15 full-version crashes, etc. System events as reported are identical thus also valid for the Plus version.

I do like to get W7FC functionality again up-and-running correctly. Please advise how to tackle this issue the best. Starting from:

- WinXP professional with all windows updates loaded
- W7FC V4.1.21.93 active but not functioning correct (new applications not discovered, blocking events for defined programs reported)
- Windows firewall disabled
- no AntiVirus installed
- Virus checked with HitmanPro
- no app's loaded except Bluetooth stack Toshiba (can be deinstalled)
- backup image available to get back to the same situation

Possibly start to investigate what's wrong with V4.1.21.93 before loosing TCP/IP again for the third time with formal deinstallation utility??

Edit1:
- Email / remote access oke if required
- all system driver files copied for quick restoration
- autoruns checked: all required driver files present

Edit2:
- did a install of version 5.0.0.15 OVER the installed version 4.x (no error msg)
- system driver finally "Windows7FirewallControl.sys" is dated 17.8.2011 (correct ?)
- deleted one program entry in the Programs tab
- started the program and no alarm of new discovered application, nor blocked event.
- checked registry: HKLM/software/sphinx-soft/vista-wall/1.0/applist and application entry indeed deleted
- unclear why program is not identified again when requesting internet access (actually allowed as was before)
- this all without laptop restart
- laptop restarted and same error: program has internet access without being listed under program tab of V5.0.0.15
- (note W7FC not yet reregistered after system restore.)
PietO
 
Posts: 192
Joined: Wed Mar 02, 2011 12:09 pm

Re: Error while upgrading to 5.0.0.15

Postby VistaFirewallControl » Sun Aug 26, 2012 1:33 pm

>system driver finally "Windows7FirewallControl.sys" is dated 17.8.2011 (correct ?)

The files installed are probably dated by the date of installation as they are created as new from the installer package. So the file date is not representative.
The file size could be more descriptive
< v5.1 19072 bytes (for 32bit systems)
>= v5.1 21248 bytes (for 32bit systems)

Getting back to the main problem.
Looks like the driver version does not match the version required by the service.
As the result, the service does not interact with the driver properly and the driver can’t perform required blocking.
What to do.
Please contact our support directly, we will send you the logging version, ask to reproduce the problem under the logging and send us the log files.
We will definitely find/fix the problem.

The second potential problem may be caused by a third party driver left by a third party firewall/antivirus. A third party driver with aggressive behavior may catch the traffic before the gentle (from the system point) W7FC. As the result, no traffic processing – no ability to detect/filter the traffic.
If the catching is static, it can be checked with
LocalMachine\ SYSTEM\CurrentControlSet\Control\GroupOrderList\PNP_TDI
The key specified the drivers load order (list of TagIDs – DWORDs)
The tags (for every driver) can be found
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DriverName in Tag parameter
W7FC driver’s tag must be right after TcpIP driver’s tag
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Error while upgrading to 5.0.0.15

Postby PietO » Sun Aug 26, 2012 6:00 pm

VistaFirewallControl wrote:>system driver finally "Windows7FirewallControl.sys" is dated 17.8.2011 (correct ?)

The files installed are probably dated by the date of installation as they are created as new from the installer package. So the file date is not representative.
The file size could be more descriptive
< v5.1 19072 bytes (for 32bit systems)
>= v5.1 21248 bytes (for 32bit systems)



It can of course not be the date of installation as i did it yesterday (see my msg above). After the installation of V5.0.0.15 over V4, the file stored in the default installation directory: C:\Program files\Windows7FirewallControl\Windows7FirewallControl.sys has size: 19072 bytes. No entry made under C:\Windows\System32\drivers.

VistaFirewallControl wrote:Getting back to the main problem.
Looks like the driver version does not match the version required by the service.

As the result, the service does not interact with the driver properly and the driver can’t perform required blocking.


The driver on my image-backup for V4.1.21.93 (where the problems started) has the same date and size (7.8.2011-19072 bytes) which was the reason to mention this in my prevous msg as "questionable". Looks thus as a consistant W7FC package. Blocking WAS performed but e.g. re-identification of deleted program entries as a simple testcase not correct, neither the added IP-rule after DisableALL

VistaFirewallControl wrote:The second potential problem may be caused by a third party driver left by a third party firewall/antivirus. A third party driver with aggressive behavior may catch the traffic before the gentle (from the system point) W7FC. As the result, no traffic processing – no ability to detect/filter the traffic.
If the catching is static, it can be checked with
LocalMachine\ SYSTEM\CurrentControlSet\Control\GroupOrderList\PNP_TDI
The key specified the drivers load order (list of TagIDs – DWORDs)
The tags (for every driver) can be found
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\DriverName in Tag parameter
W7FC driver’s tag must be right after TcpIP driver’s tag


I will send the support the export of the relevant registry entries / file versions/size and request the logging version as i guess it's a quite deep issue which does not just affect me (the thread-owner also mentioned the installer crashers as i encountered as well).

Thanks for your attention!!

PS:
TCPID-tag=4
W7FC-tag=9 (control)
W7FS-tag= (service has no tag)
PNP_TDI=
09.00.00.00.05.00.00.00
01.00.00.00.02.00.00.00
03.00.00.00.04.00.00.00
09.00.00.00.06.00.00.00
07.00.00.00.0A.00.00.00
Thus right behind the TCPIP, i see the W7TC tag, but also as first entry?!
PietO
 
Posts: 192
Joined: Wed Mar 02, 2011 12:09 pm

Re: Error while upgrading to 5.0.0.15

Postby VistaFirewallControl » Mon Aug 27, 2012 2:47 pm

Not sure, it's critical, but 09 (W7FC) is mentioned twice, right after TCPIP and before TCPIP (as the first driver).
Is there a way to patch this.
Meanwhile we continue with the rest.
VistaFirewallControl
Site Admin
 
Posts: 1494
Joined: Fri Mar 27, 2009 11:25 am

Re: Error while upgrading to 5.0.0.15

Postby PietO » Thu Aug 30, 2012 9:31 am

VistaFirewallControl wrote:Not sure, it's critical, but 09 (W7FC) is mentioned twice, right after TCPIP and before TCPIP (as the first driver).
Is there a way to patch this.
Meanwhile we continue with the rest.

FYI: the first number is the number of Dword entries in the list; 9 is thus correct. In the mean time a third case entered with the problem as described in the thread-title. Will report details by Email.

Edit: the basic problem with network lost is resolved in the prerelease: 5.1.2.57. If the PNP_TDI list was corrupted, it can be corrected manually and the network restored, thus allowing an update to the latest W7FC version.
PietO
 
Posts: 192
Joined: Wed Mar 02, 2011 12:09 pm


Return to XP Edition

Who is online

Users browsing this forum: No registered users and 0 guests

cron
suspicion-preferred