Welcome
Welcome to vistafirewallcontrol

You are currently viewing our boards as a guest, which gives you limited access to view most discussions and access our other features. By joining our free community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content, and access many other special features. In addition, registered members also see less advertisements. Registration is fast, simple, and absolutely free, so please, join our community today!

Windows 7 Firewall Control Service is not running

Windows 7 Firewall Control Service is not running

Postby Adelscott » Tue Nov 24, 2009 6:58 pm

Hi,
I bought the license last week, since then I was using the windows 7 standby instead of shutting down my computer.
Yesterday I had to do a real reboot. Since then when Windows 7 starts I got a message Windows 7 Firewall Control Service is not running and the application stops.

The service is set to start automatically but it doesn't. Neither when I try to start it manually, it says Error 1053: The service did not respond to the start or control request in a timely fashion

I have no other way to make it work than uninstall/install each time I reboot.

I have Windows 7 Entreprise with Kaspersky Anti-Virus 2010

Am I missing something ?
Adelscott
 
Posts: 3
Joined: Tue Nov 24, 2009 6:50 pm

Re: Windows 7 Firewall Control Service is not running

Postby VistaFirewallControl » Wed Nov 25, 2009 9:56 am

The problem is known, but unfortunately volatile.
So there are known cases of problemless W7FC+KAV installations as well.
We still can not reproduce the problem ourselves.

For now we found that the required service (Windows7FriewallService.exe) is stopped/delayed and/or terminated by the AV.

“Error 1053” means timeout to start the service. The default value is 30000 (30sec), which is not enough with KAV.
The timeout maybe increased
http://integrityitsolutions.blogspot.com/2009/04/how-to-increase-timeout-on-startup.html

If you would like to participate In the problem investigations please contact support [at] sphinx-soft [dot] com with subj “KAV + Windows 7 Firewall Control Service is not running”
VistaFirewallControl
Site Admin
 
Posts: 1479
Joined: Fri Mar 27, 2009 11:25 am

Re: Windows 7 Firewall Control Service is not running

Postby Adelscott » Wed Nov 25, 2009 1:12 pm

Hi
thanks for the reply !
I tried the registry trick with value 180000 but it didn't work.
I'll participate in the investigation because I want this to work.
Adelscott
 
Posts: 3
Joined: Tue Nov 24, 2009 6:50 pm

Re: Windows 7 Firewall Control Service is not running

Postby wasp » Sat Nov 28, 2009 4:43 am

Have the same problem, running free version of firewall control, kav10 anti and windows 7 pro x64, not so sure its a startup problem in so much as a shutdown problem. Seems a shutdown where something else say icq doesnt shutdown, on reboot firewall control service will not load.
wasp
 
Posts: 18
Joined: Sat Nov 28, 2009 4:40 am

Re: Windows 7 Firewall Control Service is not running

Postby VistaFirewallControl » Mon Nov 30, 2009 8:59 am

>running free version of firewall control, kav10 anti and windows 7 pro x64

Please get 3.2
http://vistafirewallcontrol.freeforums.org/the-latest-betas-releases-t6.html#p9

>Seems a shutdown where something else say icq doesnt shutdown, on reboot firewall control service will not load.

W7FC can not control starting/stopping of other applications. If a third party app changes its behavior due to a specific firewall configuration (e.g. an application waits for a response from a blocked server), the problem is in the application itself and/or incorrect permissions settings for the application.
Anyway there is a sense to try 3.2 first
VistaFirewallControl
Site Admin
 
Posts: 1479
Joined: Fri Mar 27, 2009 11:25 am

Re: Windows 7 Firewall Control Service is not running

Postby wasp » Tue Dec 01, 2009 8:16 pm

I was speaking of a windows forced shutdown of a service, not a w7fc control of a service, the only times I had the service is not running message is upon a shutdown when a program or service was forced terminated at shutdown.
That said I installed beta let windows force shutdown of icq with unanswered messages and upon reboot wfc7 did start this time.
wasp
 
Posts: 18
Joined: Sat Nov 28, 2009 4:40 am

Re: Windows 7 Firewall Control Service is not running

Postby Hades » Wed Jan 20, 2010 7:26 am

I have switched from Kaspersky to Eset Nod32, and now I have the message "Windows 7 Firewall Control Service is not running" as in KAV. But in fact, this service is only delayed. It is new with Nod32, as it has worked flawlessly for 2 months. Configuration : Windows Seven, Eset Nod32 V4.0.474.0 and W7FC 3.3.5 Beta. I have increased the timeout service to 18000 without any success. It seems to be a random problem with W7FC.
Hades
 

Re: Windows 7 Firewall Control Service is not running

Postby VistaFirewallControl » Wed Jan 20, 2010 10:00 am

Could you please verify (and inform us) whether
- Windows7FirewallService exists in Task Manager running as System
- Windows7FirewallService is listed in services.msc as running or can be launched from services.msc at least
- manual attempt to run Windows7FirewallControl (the control panel) is successful.

It would help us to separate the system startup problem from pure service run problem.

Also we would like to realize the problem is in Windows7FirewallService.exe directly or in the attempt to launch the exe as service only.
How to verify.
-run cmd.exe under Admin (elevated)
- run Windows7FirewallService.exe /unregserver
- run Windows7FirewallService.exe /regserver
- run Windows7FirewallControl
- check the both are running as Admin.

To revert back
- stop Windows7FirewallControl
- wait for Windows7FirewallService.exe is stopped automatically (<1-2 mins)
- run Windows7FirewallService.exe /unregserver
- run Windows7FirewallService.exe /service


Unfortunately modern AVs are very nifty and there is no way to predict what and how the AVs check.

The confirmed/fixed problem with KAV was the following. KAV for unknown reason delayed the service start, services.msc (the service control manager) after a reasonable timeout decided the service hung and simply terminated the entire service process. So the service was effectively unable to launch. The fix just moved almost all the required initialization into a background thread and report the OK state to the service manager nearly immediately after the service start. It appeared enough. It should be noticed however that not every KAV installation produced the service start delay; we were not able to reproduce the problem ourselves. The involved in the investigation users reported that playing with the timeout was helpful if the value was increased significantly only. So most probably the problem was not PC performance dependent. No KAV configuration dependencies were revealed as well.


We suspect the problem is not with the service delay directly. It seems NOD started preventing the service from running completely after a next AV database update (for instance or a new service related option was introduced).
If you would like to participate in the investigation (and the problem is stable) we could provide you with the logging version. Please contact support [at] sphinx-soft [dot] com for the continuation referring this forum thread.
VistaFirewallControl
Site Admin
 
Posts: 1479
Joined: Fri Mar 27, 2009 11:25 am

Re: Windows 7 Firewall Control Service is not running

Postby Hades » Wed Jan 20, 2010 11:07 am

Thank you for your quick and exhaustive answer, and sorry for my english (french speaking...).
I have tried to answer to your questions.

- Windows7FirewallService exists in Task Manager running as System : Yes
- Windows7FirewallService is listed in services.msc as running or can be launched from services.msc at least: Yes

Windows7FirewallService and Windows7FirewallControl are effectively running each time, they are only delayed. First, I have a pop-up message saying that Windows7FirewallServic is not running, after that the splash screen of NOD32, and finally the icon of Windows7FirewallControl appears in the taskbar. The Windows7FirewallService is running correctly. It seems that the error message has nothing to do with the functioning of W7F, it is just annoying (coming too soon?).
I have tried the suggested commands under Admin level;
C:\Program Files>cd Windows7FirewallControl
C:\Program Files\Windows7FirewallControl>Windows7FirewallService.exe /unregserver (see picture of pop-up)
C:\Program Files\Windows7FirewallControl>Windows7FirewallService.exe /regserver
C:\Program Files\Windows7FirewallControl>Windows7FirewallControl
and then yes, both are running as Admin.
After that, running Windows7FirewallService.exe /unregserver gives the message "Not a valid Win32 application". Same for Windows7FirewallService.exe /service.
Attachments
W7FC.jpg
W7FC.jpg (16.45 KiB) Viewed 3838 times
Hades
 

Re: Windows 7 Firewall Control Service is not running

Postby VistaFirewallControl » Wed Jan 20, 2010 11:37 am

Most probably the problem is simpler than expected before.
“Windows7FirewallService is not running” message is the message of Windows7FirewallControl (the panel) reporting that it just can’t connect to Windows7FirewallService (the service). Usually the “can’t connect” is caused by the service unavailability.
However, as you have finally the both (the service and the panel) running, the problem may be just a too short timeout of the panel waiting for the connection to the service. It’s about 2 mins by default.
The question is how long does your system start. Say if the panel is launched but CPU/disk are significantly occupied by NOD’s related procedures, after those 2 mins you may be shown with the “Windows7FirewallService is not running” message. In that case the manual panel re-launch should help always. Correct? Regardless of whether /service or /regserver…..
Please verify the hypothesis and would just increase the panel-to-service waiting timeout.

>and then yes, both are running as Admin.
It’s another implicit confirmation of the hypothesis above, isn’t it?
>see picture of pop-up
The reason is simple. Sorry we should ask you to stop the panel before “/unregserver”.
After “/unregserver” the panel could not find the service and reported the error.


>"Not a valid Win32 application".
Most probably it’s an accident as you launched Windows7FirewallService.exe before successfully.
VistaFirewallControl
Site Admin
 
Posts: 1479
Joined: Fri Mar 27, 2009 11:25 am

Next

Return to Specific behavior

Who is online

Users browsing this forum: No registered users and 0 guests

cron
suspicion-preferred